Author Topic: MAC problem, bug?  (Read 215 times)

Peter

  • Newbie
  • *
  • Posts: 22
    • View Profile
MAC problem, bug?
« on: February 15, 2020, 01:15:25 PM »
I just made a fresh install of an iMac computer with Cubase and The River connected via Panel USB.
And now, after played with The River through Cubase, when I shut down Cubase The River freeze. Cant do anything with the controls, but Riverkey is still working.
Its not until I open Macs Midi Studio everything start working again.
I didnt have this problem with My Windows PC.

Edit: OK, now I have used the combination iMac and The River for a while and The River even freeze when not using Cubase. Dont know why, but open up the Midi Studio in Mac release the freeze.
This was not so funny, I thought MAC would be more stable than Windows when it comes to Audio Midi functions.
Anyone else using MAC with The River that dont have this problem?


« Last Edit: February 15, 2020, 06:09:22 PM by Peter »

SugarFree

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: MAC problem, bug?
« Reply #1 on: February 15, 2020, 11:43:54 PM »
I've never had The River freeze with a Mac. I'm on Catalina, Nuendo 10.

Peter

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: MAC problem, bug?
« Reply #2 on: February 16, 2020, 10:46:14 AM »
I've never had The River freeze with a Mac. I'm on Catalina, Nuendo 10.

Thank you for your answer, good to hear that you have no problems with this.
I had a little bit more time now to test different midi connections to see were the problem is, and I don't think it is The River causing it, I think there is some conflict in some of the MIDI drivers on my Mac. And that makes The River freeze when it's connected to MIDI. But my other synths with USB Midi don't show this behaviour.







Peter

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: MAC problem, bug?
« Reply #3 on: February 17, 2020, 10:10:19 AM »
I decided to do a fresh OS install of my Imac, but the problem is still there.
When I start the computer and then start to play on The River I can play 2-3 tones, then it freeze.
The only way to make the freeze release is to open MIDI Studio in MAC.
Maybe its that Im not used to how MAC works, does MIDI studio always have to opened up and be active before you can use synths connected with MIDI?
In Windows I didn't have to think about something like that.









maisonvague

  • Newbie
  • *
  • Posts: 7
    • View Profile
Re: MAC problem, bug?
« Reply #4 on: February 17, 2020, 04:22:36 PM »
I can also confirm that MIDI (both DIN and USB) is working properly under Mac OS High Sierra.

When I first got my River, however, I was also experiencing consistent crashing while using Ableton Live. Oddly enough, it would never crash using Logic X. I finally traced the problem to Ableton itself which uses a non-standard MIDI NRPN implementation.

One thing to watch out for, though, are MIDI feedback loops between The River and your DAW. This is especially true if you have more than one of The Riverís three possible MIDI connections going at one time (USB Key, USB Panel and DIN MIDI).


SugarFree

  • Newbie
  • *
  • Posts: 38
    • View Profile
Re: MAC problem, bug?
« Reply #5 on: February 17, 2020, 10:09:19 PM »
One thing to watch out for, though, are MIDI feedback loops between The River and your DAW. This is especially true if you have more than one of The Riverís three possible MIDI connections going at one time (USB Key, USB Panel and DIN MIDI).

Yes, a MIDI feedback loop can cause a freeze on The River.
Another reason can be a faulty USB hub. Is The River plugged directly to your Mac?

Peter

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: MAC problem, bug?
« Reply #6 on: May 04, 2020, 10:07:18 AM »
Thankfully the new 1.91 update solved this problem for me! :)

Baloran

  • Administrator
  • Full Member
  • *****
  • Posts: 186
    • View Profile
    • Baloran SAS
Re: MAC problem, bug?
« Reply #7 on: May 04, 2020, 07:10:13 PM »
Super, thanks for this info ;)